Support for Jenkins Pipeline

The Pipeline plugin was released in December 2014. For architectural reasons, plugins providing various extensions of interest to builds cannot be made automatically compatible with Pipeline. To use plugins from Pipeline, plugins typically require use of some newer APIs, large or small.

The minimum version of Jenkins for running this plugin is 1.580.1, so if you are running an older version and you would like to use this plugin, then you will need to upgrade.

Pipeline Compatibility

The Jenkins Pipeline project maintains a Pipeline compatibility document that captures the ongoing status of plugins known to be compatible or incompatible.

Updating Jenkins plugins to be more compatible with the new Pipeline system is an ongoing community effort and CloudBees is contributing to the effort by allocating time in development schedules to work on prioritized plugins. 

Have more questions? Submit a request

0 Comments

Article is closed for comments.