0

CJOC and CM under proxy not working with CB DevOptics

I have my CJOC and CM under a proxy.

 

What port is using the DevOptics server and what rules I'll need to add?

Also, Do I need to set up these rules in each master and CJOC or only on the masters?

5 comments

  • Avatar
    Stephen Connolly Official comment

    The DevOptics plugin sends data to the following Base URL:

    https://devoptics.cloudbees.com:443/

    The actual IP address may vary, but the port is always 443 and it is always accessed by hostname.

  • 0
    Avatar
    Ryan Campbell

    Hi Javi. As I understand it, you are trying to DevOptics in an environment with an HTTP proxy, is that right?

    When you say that this isn't working with DevOptics, what do you mean? Do you see an error somewhere, perhaps in the logs?

    About the rules, I guess you are saying that you need to know the host and port name of the DevOptics servers so that you can create exceptions for these in your firewall to allow the egress communication, is that right?

  • 0
    Avatar
    Javier Raez Rus

    Hi Ryan,

    Thanks for your quick response. 

    I'm trying to run DevOptics in our test environment where we have an HTTP proxy installed.

    When we try to connect the test master with the Devoptics server we are getting that error:

    " Not Connected

    This master is NOT connected to the DevOptics service.

    An error occured while trying to connect to the DevOptics service. Please contact CloudBees support

    Error: 502"

    We have a very restrictive HTTP proxy settings and basically what we need to know are the ports and host that the DevOptics server uses in order to create the exception in our firewall.

    Thanks,

  • 0
    Avatar
    Eduardo Pelegri-llopart

    Hi Javier.   We just use https but we are a SaaS running on AWS so the end point will vary.   Let me double-check the situation with the relevant engineers and will get back to you.

  • 0
    Avatar
    Javier Raez Rus

    Thanks so much, Stephen, I have opened the port 443 for that DNS and worked for me.

Please sign in to leave a comment.