[CloudBees CI 2.277.1.2] ASM Upgrade

Issue

As part of 2021 March release, Jenkins LTS (2.277.1) and CloudBees CI (2.277.1.2) update the ASM Java bytecode manipulation and analysis framework that is used for bytecode processing in many plugins.

Why is this Important?

This update affects plugins that depend on ASM for bytecode processing.
Some older plugin releases may report a RuntimeException with the message Error creating extended parser class (like Token Macro plugin).
Other older plugin releases may fail to interpret existing settings (like Email Extension plugin).

What would an error look like?

An incompatible plugin will generate an error like

FATAL: Error creating extended parser class: null

Environment

Resolution

All CloudBees and CAP plugin have been updated to be compatible with this change.

To ensure these plugins are updated please be sure to enable CAP/Beekeeper and allow for automatic plugin updates on restart prior to updating your CloudBees CI version as explained in the documentation linked here.

For tier 3 plugins use the Plugin Manager to update plugins affected by the ASM update after upgrading to Jenkins 2.277.1 or CloudBees CI 2.277.1.2.

Have more questions?

0 Comments

Please sign in to leave a comment.