Beekeeper issues with CloudBees Core 2.176.3.2

Issue

Attempting to apply an incremental upgrade from 2.176.3.2 to 2.176.3.2 revision 2 results in Jenkins displaying an IllegalAccessError:

Stack trace

java.lang.IllegalAccessError: tried to access method com.cloudbees.jenkins.plugins.assurance.StagingURLSource.getPlugin(Lcom/cloudbees/jenkins/plugins/updates/envelope/ValidationContext;Lcom/cloudbees/jenkins/plugins/updates/envelope/EnvelopePlugin;)Ljava/net/URL; from class com.cloudbees.jenkins.plugins.assurance.Staging
	at com.cloudbees.jenkins.plugins.assurance.Staging.prepare(Staging.java:103)
	at com.cloudbees.jenkins.plugins.assurance.Staging.access$000(Staging.java:30)
	at com.cloudbees.jenkins.plugins.assurance.Staging$1.apply(Staging.java:72)
	at com.cloudbees.jenkins.plugins.assurance.Staging$1.apply(Staging.java:68)
	at com.cloudbees.jenkins.plugins.updates.envelope.Validation$Value.flatMap(Validation.java:229)
	at com.cloudbees.jenkins.plugins.assurance.Staging.of(Staging.java:68)
	at com.cloudbees.jenkins.plugins.assurance.UpgradeAction.stage(UpgradeAction.java:242)
	at com.cloudbees.jenkins.plugins.assurance.model.OfferedUpgrade$AbstractIncremental.pick(OfferedUpgrade.java:381)
	at com.cloudbees.jenkins.plugins.assurance.UpgradeAction.doUpgrade(UpgradeAction.java:109)
	at java.lang.invoke.MethodHandle.invokeWithArguments(MethodHandle.java:627)
	at org.kohsuke.stapler.Function$MethodFunction.invoke(Function.java:396)
	at org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:408)
	at org.kohsuke.stapler.interceptor.RequirePOST$Processor.invoke(RequirePOST.java:77)
	at org.kohsuke.stapler.PreInvokeInterceptedFunction.invoke(PreInvokeInterceptedFunction.java:26)
	at org.kohsuke.stapler.Function.bindAndInvoke(Function.java:212)
	at org.kohsuke.stapler.Function.bindAndInvokeAndServeResponse(Function.java:145)
	at org.kohsuke.stapler.MetaClass$11.doDispatch(MetaClass.java:535)
	at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:58)
	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:747)

Environment

Resolution

You are facing a defect in the release 2.176.3.2-rolling.

We are providing a new full release 2.176.3.3 which provides the same benefits as the 2.176.3.2 revision 2 update.

The error does not break your instance; the instance remains healthy and operational.
However, if you are running 2.176.3.2, we strongly recommend that you upgrade to the 2.176.3.3 release.
This requires a full upgrade of the installed distribution instead of the incremental upgrade previously provided.

Download link

https://go.cloudbees.com/downloads/index.html

Release notes

Have more questions?

0 Comments

Please sign in to leave a comment.