After updating Jenkins I am getting an error when trying to create or modify an agent within Jenkins

Issue

  • When trying to create or modify an agent within Jenkins I am getting the following error:
Stack Trace
org.apache.commons.jelly.JellyTagException: jar:file:/var/jenkins_home/war/WEB-INF/lib/jenkins-core-$JENKINS_VERSION.jar!/jenkins/model/Jenkins/configure.jelly:51:84: <st:include> org.apache.commons.jelly.JellyTagException: jar:file:/var/jenkins_home/war/WEB-INF/lib/jenkins-core-$JENKINS_VERSION.jar!/lib/form/section.jelly:48:21: <d:invokeBody> org.apache.commons.jelly.JellyTagException: jar:file:/var/jenkins_home/war/WEB-INF/lib/jenkins-core-$JENKINS_VERSION.jar!/lib/form/block.jelly:32:22: <d:invokeBody> org.apache.commons.jelly.JellyTagException: jar:file:/var/jenkins_home/plugins/$CLOUD_NAME/WEB-INF/lib/$CLOUD_NAME.jar!/org/jenkinsci/plugins/$CLOUD_NAME/config.jelly:94:83: <j:forEach> hudson/slaves/CommandLauncher
	at org.apache.commons.jelly.impl.TagScript.handleException(TagScript.java:726)
	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:281)
	at org.kohsuke.stapler.jelly.CallTagLibScript$1.run(CallTagLibScript.java:99)
	at org.apache.commons.jelly.tags.define.InvokeBodyTag.doTag(InvokeBodyTag.java:91)
	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269)
	at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
	at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:161)
	at org.apache.commons.jelly.tags.core.OtherwiseTag.doTag(OtherwiseTag.java:41)
	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269)
	at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
	at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:161)
	at org.apache.commons.jelly.tags.core.ChooseTag.doTag(ChooseTag.java:38)

Environment

Resolution

Due to the security concerns expressed in JENKINS-47393, the Launcher was moved out of core into a plugin that could depend on tools such as “script-security” for approval. This means that that your agent launching library is no longer being loaded since it is now kept in an external plugin.

Resolution Install the Command Agent Launcher Plugin

Have more questions?

0 Comments

Please sign in to leave a comment.