Operation Center Plugins are stuck to version 2.7.0.0 after an upgrade of the Operation Center from 2.7.21.1 to 2.121.1.2 with CAP enabled

Issue

After the upgrade, some Operation Center plugins cannot be upgraded to the version advertised in the envelope.
The update tab looks like:

UC screenshot

Environment

Explanation

Between the two versions, the mesos plugin was excluded from the plugin envelope,
therefore it cannot be updated from the version 0.13.x that came with the envelope for the Operation Center 2.7.21.1.

In addition, the new versions of various Operation Center Plugins have an optional dependency over the mesos plugin
version 0.14.y.
Those plugins won’t be installable until either the mesos plugin is uninstalled or upgraded.

Resolution

If you read this KB before the upgrade

You can workaround this issue by doing a two step upgrade:

  • First upgrade your Operation Center to version 2.89.4.2.
  • Make sure the mesos plugin got upgraded to the version 0.14.1 (it should be upgraded automatically because of
    transitive dependencies upgrades).
  • Then upgrade your Operation Center to a more recent version.

If you read this KB after the upgrade (and therefore you have the issue)

You have two ways of dealing with the problem:

  • If you don’t use the mesos plugin, you can just uninstall it, then you will be able to upgrade the stuck plugins.
  • If you are using the mesos plugin, then you can deactivate the CAP (more about the CloudBees Assurance Program),
    upgrade the mesos plugin to a more recent version and reactivate the CAP.
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.