How to find the CloudBees Support Tier for a certain Jenkins plugin?

Issue

  • What level of support does CloudBees offer for a specific plugin?

Environment

This information is relevant to all CloudBee Jenkins Solutions, including the following packages:

Resolution

Use the following links to understand the level of support provided for each plugin:

A - The CloudBees Support Plugin Policies article that describes the different CloudBees support Tiers for plugins.

B - The CloudBees Release Notes page.

  • Choose your product and then the release you are running.
  • From that page, click on the “Plugin” tab.
  • This lists the plugins for this, grouped as “verified,” “proprietary,” and “compatible”.
  • All other plugins are considered to be “Tier 3” - Community maintained and Unknown plugins.

Notes:

  1. All CloudBees Proprietary plugins are verified on all appropriate CloudBees products.
  2. There are specific plugins that cannot be installed in any of their versions because they have been blacklisted by jenkins.io or CloudBees.

Example

For CJP Client Master 2.107.1.2 > plugins tab.

CloudBees Role-Based Access Control Plugin

  • Its version 5.19 is included into the CJP Client Master 2.107.1.2 envelope.
  • It is a Proprietary plugin - Verified (Tier 1).
  • It is required.

JUnit Plugin

  • Its version 1.23 is included in the CJP Client Master 2.107.1.2 envelope.
  • It’s an Open Source plugin - Verified (Tier 1).
  • It is required.

Pipeline

  • Pipeline 2.5 is inside the CJP Client Master 2.107.1.2 envelope.
  • It is an Open Source plugin - Compatible (Tier 2).
  • It is optional to install.

Job DSL

  • Job DSL plugin is out of the CJP Client Master 2.107.1.2 envelope. However, its version 1.69 can be installed having Beekeeper enabled because it does not break any of the envelope dependencies.
  • It is an Open Source plugin - Community maintained and Unknown plugins (Tier 3).

Note: Required plugins are those ones that are bundled in a specific CloudBees product whereas Optional plugins can be installed or not by the end user depending on their needs.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.