Upgrading to Pipeline Plugin v2.0

Issue

Upgrading to Pipeline Plugin v2.0

Environment

Cloudbees Jenkins Enterprise

Jenkins

Resolution

Upgrading to Pipeline Plugin v2.0 requires a minimum Jenkins core version of 1.642.3.
Pipeline v2.0 also has a dependency on the following plugins:

Pipeline Job v2.0 Plugin

Pipeline Supporting APIs v1.15 Plugin

Durable-task v1.5 Plugin

Pipeline API v2.0 Plugin

Script-security v1.16 Plugin

Pipeline Step API v1.15 Plugin

Structs v1.1 Plugin

Here is a link to a post by Jesse Glick about Pipeline 2.x plugins.

If you upgrade to Pipeline Plugin v2.0 and experience an issue, please generate a new
Support Bundle, decompress it, and check the failed.txt file inside the plugins
directory. The failed.txt file will show missing plugin dependencies.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.