Operations Center plugins versions

Issue

Which versions of Operations Center plugins have to installed?

Environment

  • CloudBees Jenkins Operations Center
  • CloudBees Jenkins Enterprise
  • Jenkins

Resolution

Operations Center Server plugin is deployed on CloudBees Jenkins Operations Center.
Operations Center Client plugin is deployed on CloudBees Jenkins Enterprise.

On any Jenkins instance, that Jenkins instance must be running the same major.minor of all Operation Center plugins.

Operations Center Server and Operations Center Client plugins are following the works with -1 +1 model. This means that you can have a client master running all the 1.7.x plugins and connect it to a 1.8.x CJOC but you can also have a client master running all the 1.8.x plugins and connect it to a 1.7.x CJOC.

The 1.7.x line of Operations Center Client plugin is to assist upgrading from CloudBees Jenkins Operations Center 1.6 as that is the only Operations Center Client line that can talk to a CloudBees Jenkins Operations Center 1.6.x and is the only one that work on (CloudBees) Jenkins (Enterprise) 1.580-1.608.

It is recommended to upgrade Operations Center Client plugin to the latest versions (1.8.x nowadays).

You do not need to have all client masters on the same version of Jenkins (core).

You do not need to have all client masters on the same major.minor of the Operations Center plugin but on a given instance:

  • all Operation Center plugins must internally be consistent in their major.minor
  • Operations Center Client plugin can only talk to +/-1 minor version of CloudBees Jenkins Operations Center.
Have more questions? Submit a request

2 Comments

  • 0
    Avatar
    Alexander Ost

    The -1 +1 model means that 2.7.x.x plugins on CM side must not be combined with 2.19.x.x plugins on CJOC side. Is that correct?

     

     

  • 0
    Avatar
    Dan Tranter

    Just wanted to note this page generally applies to 1.X OC plugins, as some versions of OC plugins have dependencies...(in particular, the 1.8.10X versions of oc-agentoc-client, oc-context) and these must be updated together on a JE master instance.  

    For CloudBees Jenkins Platform 2.X, the complete list of Operations Center and Jenkins Enterprise versions (and bundled plugins for each), separated into "required" and "optional" can be found here

Please sign in to leave a comment.