gradle-failure-initializing-default-system-SSL-context

Issue

This is a Gradle build which had successful results in the past with the same set of dependencies. Now, It always fails to download a dependency with the following error:

Could not resolve org.name.module:artifact:1.47.
Required by:
org.name.module:artifact:1.0.0
Could not resolve org.name.module:artifact:1.47.
Could not get resource ’https://repo1.maven.org/maven2/org/name/module/1.47/module-1.47.pom'.
Failure initializing default system SSL context

Environment

  • CloudBees Jenkins Enterprise > 1.596.1.1
  • Jenkins LTS > 1.596.1
  • Jenkins > 1.600
  • Gradle < 2.11-rc-1

Resolution

Seems like Gradle have an issue with parallel execution, it causes this error. To solve it you have to disable parallel build (org.gradle.parallel=false).
Another solution is to upgrade Gradle to version 2.11-rc-1 or higher.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.