Issue
- JDK Installer for java.sun.com displays a text field instead of a dropdown list
- Cannot use JDK Installer
Environment
- CloudBees Jenkins Enterprise
Root cause
This is a problems of the basic function of the update center. The update center does not fetch the latest data file for the JDK Installer.
Resolution
This can be fixed inside a running instance of CJE.
Delete the failing JDK installers
- Got to
Manage Jenkins/Configure System
- Remove the JDK installer
Force Jenkins to update the JDK Installer data file:
-
Go to
Manage Jenkins/Script Console
-
Copy/Paste and Run this groovy script that will update the data file for tools and installers:
hudson.model.DownloadService.signatureCheck = false hudson.model.DownloadService.Downloadable.get("hudson.tools.JDKInstaller").updateNow() hudson.model.DownloadService.signatureCheck = true return
-
The script might take few seconds to finish. A label
Result
appears below the Text Area indicating that the script has run.This line should appears in the log as well:
... INFO: Obtained the updated data file for hudson.tools.JDKInstaller ...
-
Go to
Manage Jenkins/Configure System
-
Add a JDK Installation and select the java.sun.com JDK Installer. There should be a dropdown list.
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