Failed plugins when installing Blue Ocean 1.0

Issue

After disabling the CloudBees Assurance Program and then installing Blue Ocean 1.0, some plugins may fail to be installed. The steps to reproduce this would be:

  1. Start a fresh instance of CJT 2.32.3.1
  2. Install all suggested plugins
  3. Leave CAP
  4. Try to install Blue Ocean 1.0.0

Environment

  • Blue Ocean 1.0
  • Jenkins

Resolution

The problem basically happens because during the initial plugin installations, some plugins related with Declarative Pipeline are installed in version 1.0.2 but Blue Ocean 1.0.0 requests at least versions 1.1.1 of these plugins.
Because of how Jenkins works when installing plugins, some plugins fail to dynamically load because of dependency requirements, let’s not get into much detail here for now.

Solution

If you restart, all plugins get properly installed and you have Blue Ocean 1.0.0 fully installed and working.

This all boils down to what is installed in a CJT, Client Master or Managed Master by default in 2.32.x line (which is determined by the CloudBees Assurance Program) and what plugins need to be updated to be able to install Blue Ocean.

One example:

  • Pipeline: Model API is in version 1.0.2 (required by BO RC1) and version 1.1.1 needs to be installed for BO GA version. The installation is successful (yellow ball, will be effective after a restart)
  • Pipeline: Declarative Extensions Points API is in version 1.0.2 and needs to be installed in 1.1.1 but for 1.1.1 to be installed, it requires that Pipeline: Model API is installed in 1.1.1, which is not (until the next restart). So it fails. When you see the error trace this error is not obvious, it just says if failed to dynamically load the plugin.

This install behavior is purely a bug in the Jenkins install experience, and not caused by Blue Ocean or CloudBees.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.